Join the 80,000 other DTN customers who enjoy the fastest, most reliable data available. There is no better value than DTN!

(Move your cursor to this area to pause scrolling)

"If someone needs the best quality data and backfill beyond what their broker provides at a rate that is the best in the industry, I highly recommend IQFeed." - Comment from Josh via Public Forum
"As a past ******* customer(and not a happy one), IQ Feed by DTN is a much better and cheaper product with great customer support. I have had no problems at all since switching over." - Comment from Public Forum
"Thank you so much - awesome feed, awesome service!" - Comment from Greg via Email
"You are either overstaffed or people just don't have problems with your feed because customer support always answers the phone quickly." - Comment from Jay via Email
"IQFeed version 4 is a real screamer compared to anything else I have seen." - Comment from Tom
"There is no doubt that IQFeed is the best data provider. I am very satisfied with your services. And IQFeed is the only one that I would recommend to my friends. Now, most of them are using your product in China." - Comment from Zhezhe
"I noticed that ******* quotes locked up shortly after the interest rate announcement yesterday while yours stayed stable." - Comment from Ron in Utah
"Can I get another account from you? I am tired of ******* going down so often" - Comment from George
"And by the way, have to say this. I love the IQFeed software. It's rock solid and it has a really nice API." - Comment from Thomas via RT Chat
"I am very pleased with the DTNIQ system for quotes and news." - Comment from Larry
Home  Search  Register  Login  Recent Posts

Information on DTN's Industries:
DTN Oil & Gas | DTN Trading | DTN Agriculture | DTN Weather
Follow DTNMarkets on Twitter
DTN.IQ/IQFeed on Twitter
DTN News and Analysis on Twitter
»Forums Index »Archive (2017 and earlier) »IQFeed Developer Support »Bad historical data on
Author Topic: Bad historical data on (3 messages, Page 1 of 1)

-Interested User-
Posts: 28
Joined: Apr 9, 2005

Posted: Oct 21, 2008 08:03 AM          Msg. 1 of 3
I have two machines I use to connect to IQFeed. They always seem to be 'sticky about which IP they connect too and both act differently. One always seems to connect to and I get good historical data. The other seems 'sticky' on and I consistently get messages '!ERROR! Invalid symbol.' A test symbol that gives this error is 'SPX.XO'. The registry settings on both machines appear to be the same and I can not find where the sticky IP comes from. They are both running

So two questions:
1. Why am I getting these invalid symbols on *.150 and not *.116?
2. How can I change the IP I connect to?

BTW, I do not use the feed on both computers at the same time.

-DTN Guru-
Posts: 2093
Joined: Nov 21, 2005

Posted: Oct 21, 2008 11:19 AM          Msg. 2 of 3
simon, you can not specify which server you connect to. However, there are ways to change which server farm you connect to. We do not recommend this because they bypass load balancing and would cause you to not connect if the server farm you are pointing to went down for whatever reason. is the server IP address for our Pre-Production server farm. I suspect that at some point you were testing out some new features from that computer and switched your hosts file to point to that server and forgot to change it back. In order to resolve this, you will want to open up your hosts file and remove the line directing to Your hosts file is usually located in the C:\Windows\System32\drivers\etc\

If you are unsure about the process or cannot find the file, please contact our support department for assistance.

-Interested User-
Posts: 28
Joined: Apr 9, 2005

Posted: Oct 21, 2008 03:16 PM          Msg. 3 of 3
That is exactly what happened (I was having the issue on my development machine). I modified the hosts file and volia. I had forgotten about that.

Thanks again!


Time: Sat February 24, 2024 1:45 PM CFBB v1.2.0 9 ms.
© AderSoftware 2002-2003