Join the 80,000 other DTN customers who enjoy the fastest, most reliable data available. There is no better value than DTN!

(Move your cursor to this area to pause scrolling)




"I used to have *******, but they are way more money for the same thing. I have had no probs with data from DTN since switching over." - Comment from Public Forum Post
"I'm very glad I switched to IQFeed. It's working perfectly with no lag, even during fast market conditions." - Comment from Andy via Email
"Everything is working amazing now. I'm already impressed with the true-tick feed of IQFeed and it's ability to support my 480 symbol layout." - Comment from Tyler via Email
"I "bracket trade" all major news releases and I have not found one lag or glitch with DTN.IQ feed. I am very comfortable with their feed under all typical news conditions (Fed releases, employment numbers, etc)." - Comment from Public Forum
"I will tell others who want to go into trading that DTN ProphetX is an invaluable tool, I don't think anyone can trade without it..." - Comment from Luther
"Awesome response, as usual. It is a sincere and refreshing pleasure to do business with DTN, compared to your competition." - Comment from Ryan
"This is an excellent value, the system is generous (allowing for 500 stocks) and stable (and really is tick-by-tick), and the support is fantastic." - Comment from Shirin via Email
"Thanks for following up with me. You guys do a great job in tech support." - Comment from Phelps
"Thanks for all of your help. Great customer service deserves to be recognized which one the reasons I've been a customer of DTN for over 10 years!" - Comment from Stuart
"I have to tell you though that using the IQFeed API is about the easiest and cleanest I have seen for some time." - Comment from Jim
Home  Search  Register  Login  Blogs Recent Posts

Information on Various DTN Products:
DTN IQFeed | DTN ProphetX | DTN Ag | NxCore
Follow DTN_IQFeed on Twitter
DTN.IQ/IQFeed on Twitter
DTN News and Analysis on Twitter
Viewing User Profile for: tccharleton
About Contact
Joined: Dec 2, 2014 08:23 AM
Last Post: May 6, 2016 07:16 AM
Last Visit: Nov 6, 2016 12:00 PM
Website:  
Location:
Occupation:
Interests:
Avatar:
Reluctant but dedicated nerd.
AIM:
ICQ:
MSN IM:
Yahoo IM:
Post Statistics
tccharleton has contributed to 24 posts out of 18336 total posts (0.13%) in 1,178 days (0.02 posts per day).

20 Most recent posts:

Check out the thread below. I had a similar problem and I found a solution. It may not work but it might be related.

http://forums.dtn.com/index.cfm?page=topic&topicID=4195


Thanks for the feedback. I apologize for the terrible syntax in my previous post. I obviously didn't review it before I hit the button. Seriously, I am glad that it helped you despite my language problems.


Sorry for the delayed update but I wanted to make sure it worked before posting anything here that might help someone in the future.

The problem I had was related to the standard Wine packages that were available to the Ubuntu image that I was using on Amazon AWS. I has nothing to do with it being From AWS but rather the Wine version that was installed when I executed the apt-get install on the particular image. In addition, some wine packages were still present after uninstalling Wine. Therefore I did the following and it worked for me:

Run the following command in the terminal:

sudo apt-get purge wine* (caution - this will remove ALL Wine components)


Follow the instructions in the InstallingWineHQ Packages section of the link below:
https://wiki.winehq.org/Ubuntu

Reinstall the latest release of the IQFeed software.

Good Luck!


I have worked on this all day and I think I may have discovered the issue. However, I want to make sure it works before I share the info.


Changed the file suffix to txt in order for it to be accepted on the post


Copy of the registry for the server.


JPG version of screenshot.


The issue I see with the 5.2 install is that the install hangs for a long time at the point shown in the attached screenshot.

The line Executre: "vcredist_x86_2012u4.exe" /promptrestart /passive indicates that the IQFeed install routine is attempting to run the vcre install with some kind of silent or whatever option set. (I don't know enough about the command line options for the vcre install to accurately determine what the IQFeed install routine is attempting) However, it hangs there for 1+ minutes and then indicates that it has completed the install but I cannot tell if it is just timing out. I only suspect this being a problem because I do not get this issue outside of Wine.

I removed the 5.1.x artifacts and did a fresh install of the 5.2.x client. Following this install (and reboot to be safe) I am unable to launch any of the IQF applications despite other Wine applications running normally. This is why I have been using the 5.1.x client because I simply could not get the 5.2.x client to do anything. In fact, I cannot get it to create any DTN/IQFeed log files which leads me to guess the underlying vcre never installed properly. However, not having much time to diagnose the problem, I had to move on with the 5.1.x client in place.

I am attaching more files on subsequent replies.


Additional File Attachment


Additional file attachment


Additional file attachment.


I have been running IQFeed version 5.1.x.x on Amazon AWS/ Ubuntu 14.04 and Wine. (FYI - I was unable to install version 5.2.x.x due to the reboot flag at the end of the installation routine causing Ubuntu a problem.)

Everything works great for about 24 hours then I get a crash. I have tried to troubleshoot it to no avail. I have attached the crash dumps/logs with the hope you can see what I am missing.

Many Thanks,

IQFeed Developer Support » Level1Fields for Protocol 5.2 Mar 11, 2016 12:14 PM (Total replies: 4)

Tim,

Your check enabled me to find an upstream switch statement that I did not have falling-through properly.

Many Thanks!

IQFeed Developer Support » Level1Fields for Protocol 5.2 Mar 10, 2016 02:17 PM (Total replies: 4)

I was trying to save you having to read a few lines. Attached contains the setDefaultFieldsProtocol5_1 method (which works) and the setDefaultFieldsProtocol5_2 method which does not work.

IQFeed Developer Support » Level1Fields for Protocol 5.2 Mar 10, 2016 01:50 PM (Total replies: 4)

I cannot seem to find what is wrong with my field request string for Level1Fields under protocol 5.2. I know there is something I am missing but I can't find it. Can you please verify that this request string includes valid fields?

Many Thanks!

IQFeed Developer Support » Listed Market Open Close Times Available? Dec 17, 2015 09:03 AM (Total replies: 1)

I wanted to know if there is a lookup for market open-close for a listed market by date? Since I am creating my own aggregates based on quotes, I need to roll a quote forward in time if no new quote message has been received. However, I need to know at what point would a listed market be closed in total for that particular day.

I already perform the lookup/conversion for:

Symbol->ListedMarket

AND/OR

IQFLevel1UpdateMessageTime->MillisSinceEpoch->DaysSinceEpoch/LocalDate/DayOfWeek/DayOfMonth/etc

I looked at the market open flag but couldn't determine if that was in use and for what, if any sessions beyond the regular. I have done this kind of thing before using both manual and regular updates with other data feed providers. However, I wanted to see what, if anything, is available before I begin construction on this phase.

Many Thanks!


I was missing setting the protocol version on the various services. I was only setting it on the Admin service. I am going to prune the number of fields. I was just unable to see what they contained.

Many Thanks!

IQFeed Developer Support » Cannot Connect via API Dec 1, 2015 09:28 AM (Total replies: 1)

Please disregard this post. There was an issue with my API service not auto-renewing.

IQFeed Developer Support » Cannot Connect via API Dec 1, 2015 08:56 AM (Total replies: 1)

This morning I started receiving the following message when launching iqconnect.exe from my code (as I have done many times).

I can log-in outside of my code but not launch from within it.

Sorry, your Product and/or Service for the attempted login are incorrect. If you have recently changed products you may also need to change your type of service. Please contact DTN customer support for assistance. (1)


Output file in case it didn't get attached the first time.


Time: Wed February 21, 2018 3:06 AM CFBB v1.2.0 0 ms.
© AderSoftware 2002-2003