Join the 80,000 other DTN customers who enjoy the fastest, most reliable data available. There is no better value than DTN!

(Move your cursor to this area to pause scrolling)




"Excellent datafeed !!!" - Comment from Arely
"I am very happy I changed. I love the product, but more so I am thrilled with Tech Support. You are knowledgeable, polite, pleasant and professional." - Comment from Pat
"Version 4.0.0.2 has been working well for me and I appreciate that it is now a much tighter client to work with. I feel I can go to press with my own application and rely on a stable platform" - Comment from David in IA.
"If you are serious about your trading I would not rely on IB data for serious daytrading. Took me a while to justify the cost of IQ Feed and in the end, it's just a 2 point stop on ES. Better safe than sorry" - Comment from Public Forum
"As a past ******* customer(and not a happy one), IQ Feed by DTN is a much better and cheaper product with great customer support. I have had no problems at all since switching over." - Comment from Public Forum
"Interactive Brokers tick data was inconsistent, so I have switched to using DTN exclusively. It is great to no longer have to worry about my datafeed all day long." - Comment from Philippe
"It’s so nice to be working with real professionals!" - Comment from Len
"You have an excellent feed. Very few spikes for Spot Forex." - Comment from Public Forum Post
"You have an excellent product !!!!!!" - Comment from Arely
"Very impressed with the quality of your feed - ******* is a real donkey in comparison." - Comment from A.C. via Email
Home  Search  Register  Login  Blogs Recent Posts

Information on Various DTN Products:
DTN IQFeed | DTN ProphetX | DTN Ag | NxCore
Follow DTN_IQFeed on Twitter
DTN.IQ/IQFeed on Twitter
DTN News and Analysis on Twitter
»Forums Index »IQFeed Developer »IQFeed Developer Support »IQFeed client update backwards compatibility
Author Topic: IQFeed client update backwards compatibility (3 messages, Page 1 of 1)

sevteen
-Interested User-
Posts: 4
Joined: Oct 11, 2017


Posted: Oct 24, 2017 10:35 AM          Msg. 1 of 3
Hello,

We're using client version 5.2.5.0 and it's asking to upgrade to 5.2.6.0. We're also using protocol v5.1. Will new IQFeed Client still work for protocol v5.1? In general how does IQFeed Client and protocol versioning relate to each other (if any) and how should we know if there are breaking changes in the release?

DTN_Tim Walter
-DTN Guru-
Posts: 1102
Joined: Apr 25, 2006


Posted: Oct 24, 2017 01:15 PM          Msg. 2 of 3
The upgrades should be seamless as long as the same protocol is used, regardless of upgrading. (Only true for versions 4.9 or greater.) We would alert all registered developers long ahead of any breaking changes multiple times before making a release of such a client.

Tim

sevteen
-Interested User-
Posts: 4
Joined: Oct 11, 2017


Posted: Oct 24, 2017 02:44 PM          Msg. 3 of 3
Hi Tim,

makes sense, just wanted to verify as I could not find it in written form in the docs, maybe I overlooked though.

Anyway, this is great and thanks!
 

 

Time: Tue January 16, 2018 11:31 PM CFBB v1.2.0 15 ms.
© AderSoftware 2002-2003