Join the 80,000 other DTN customers who enjoy the fastest, most reliable data available. There is no better value than DTN!

(Move your cursor to this area to pause scrolling)




"I like you guys better than *******...much more stable and a whole lot fewer issues." - Comment from Philip
"Can I get another account from you? I am tired of ******* going down so often" - Comment from George
"I ran your IQFeed DDE vs. my broker vs. a level II window for some slow-moving options. I would see the level II quote change, then your feed update instantaneously. My broker's DDE, however, would take as much as 30 seconds to update. I am not chasing milliseconds, but half a minute is unacceptable." - Comment from Rob
"I've been using Neoticker RT with IQFeed for two months, and I'm very happy with both of the products (I've had IQFeed for two years with very few complaints). The service from both companies is exceptional." - Comment from Public Forum
"You have an excellent product !!!!!!" - Comment from Arely
"Thank God for your Data Feed as the only Zippers I see are on my pants (LOL), and no more 200 pip spikes to mess up charts." - Comment from Spiro via Email
"IQ feed is brilliant. The support is mind-bending. What service!" - Comment from Public Forum Post
"As a past ******* customer(and not a happy one), IQ Feed by DTN is a much better and cheaper product with great customer support. I have had no problems at all since switching over." - Comment from Public Forum
"This beats the pants off CQG, I am definitely switching to the ProphetX 3.0!" - Comment from Stephen
"And by the way, have to say this. I love the IQFeed software. It's rock solid and it has a really nice API." - Comment from Thomas via RT Chat
Home  Search  Register  Login  Recent Posts

Information on DTN's Industries:
DTN Oil & Gas | DTN Trading | DTN Agriculture | DTN Weather
Follow DTNMarkets on Twitter
DTN.IQ/IQFeed on Twitter
DTN News and Analysis on Twitter
»Forums Index »Product Support »ProphetX Support »Installing/Running Prophet-X 2.57 in a Locked-Down Environment
Author Topic: Installing/Running Prophet-X 2.57 in a Locked-Down Environment (2 messages, Page 1 of 1)

franklesniak
-Interested User-
Posts: 2
Joined: Mar 28, 2006


Posted: Mar 30, 2006 01:27 PM          Msg. 1 of 2
Hello Again,

Since there is no upgrade path between 2.x and 3.x, and based on recommendations from technical support, we have decided to deploy both Prophet-X 3.0 and 2.57 across my client's organization. This will allow users running 2.x versions to not be interrupted when we roll out new desktops.

However, I am experiencing many issues with regard to running version 2.57 in a locked-down environment. Here are the scenarios I tried:

Installed the program as an administrator
Ran the program as a user
*Didn't work* I get the error message "Can't register server API from Prx"
Using regmon, it looks like the program is trying to write to HKCR. Next, I tried the scenario below:

Elevated a user's permissions to local admin
Ran the install as the user w/ elevated privileges
Started the program, runs fine. Was able to connect to server.
Closed program
Removed local admin privledges from user
Started the program again, prompted for login
Pressed OK to login
*Didn’t work* Error message “Connection Failed: No Router File”
Using filemon, it is clear that Prophet-X is accessing the incorrect location for the routers.dat file. It is looking for the file in C:\Program Files\FIMI\ProphetX\My ProphetX Files (correct location is C:\Program Files\FIMI\ProphetX). The strange part is that regmon shows that it read the location of the router file correctly, and filemon shows that it was able to access the (correct) file earlier, before I click OK to login.
If I re-elevate the user to local admin, the logon works with no error message. I can’t find any indication (using filemon or regmon) as to why Prophet-X “knows” the correct file location when run with administrative privileges and not with regular user privileges. When I run as an administrator, Prophet-X simply goes to the correct location without any failure messages. There is no indication that Prophet-X is able to access any "new" or "different" registry information as an admin either.

I have tried other techniques, such as repackaging (using InstallShield’s Repackager), but the same thing happens. The GPO here is not very strict, either.

Elevating every user that needs Prophet-X to local admin is definitely unacceptable at this organization. Is there another way around this? There must be some way to run this program without being a local administrator…?

Thanks for your help!
Frank Lesniak
West Monroe Partners, LLC

margep
-DTN Evangelist-
Posts: 119
Joined: Sep 13, 2005


Posted: Mar 30, 2006 01:34 PM          Msg. 2 of 2
We don't have a way to get in touch with you!
Our tech support group is waiting for your call - please call them at 1-800-532-0136
Thanks
 

 

Time: Tue June 18, 2019 6:07 PM CFBB v1.2.0 15 ms.
© AderSoftware 2002-2003